• WAP手机版 RSS订阅 加入收藏  设为首页
通达信选股

通达信公式:爱不释手最好的通达信选股公式集

时间:2017/12/5 5:15:01  作者:  来源:  查看:54  评论:0
这些爱不释手的通达信公式,一定能战胜股市!!

短线追涨
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1;
B:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A1:=A AND B;
AA:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BA:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A2:=AA AND BA ;
AAA:=BARSLAST(CROSS(97,GJTJ1))<=3 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAA:=BARSLAST(CROSS(97,GJTJ2))<=3 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A3:=AAA AND BAA ;
B1:=REF(A1,1);
B2:=REF(A2,1);
B3:=REF(A3,1);
D1:=GJTJ1=100 AND GJTJ2=100   AND A1;
D2:=GJTJ1=100 AND GJTJ2=100   AND A2;
D3:=GJTJ1=100 AND GJTJ2=100   AND A3;
ENTERLONG: D1 OR D2 OR D3;

白金点灯
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
B:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
E:=GJTJ1>60 AND GJTJ4>70;
ENTERLONG:A AND B   AND E;

黄金点灯
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;
B:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
ENTERLONG:A AND B;

起涨首日
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(95,GJTJ1))<=2;
B:=BARSLAST(CROSS(95,GJTJ2))<=2;
E:= GJTJ4<GJTJ1 AND GJTJ1<GJTJ2 AND GJTJ1<GJTJ3;
F:=GJTJ2>50 AND GJTJ3>50;
G:=GJTJ1=100 AND GJTJ2=100;
TX:=COUNT(G,2)=1;
ENTERLONG:A AND B AND E AND F AND TX;

波启前兆
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=GJTJ3=100;
B:=GJTJ4<90;
ENTERLONG:COUNT(A,2) = 2 AND B;

黄金三角
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
BAIJIN1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
BAIJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
BAIJIN3:=GJTJ1>60 AND GJTJ4>70;
M1:=BAIJIN1 AND BAIJIN2 AND BAIJIN3;
HUANGJIN1:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;
HUANGJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
M2:=HUANGJIN1 AND HUANGJIN2;
XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5   AND GJTJ1>GJTJ4;
M3:=COUNT(XG,3)=1 AND XG AND C>MA(C,20);
操盘手: M1 OR M2 OR M3;

操盘手
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
BAIJIN1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
BAIJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
BAIJIN3:=GJTJ1>60 AND GJTJ4>70;
M1:=BAIJIN1 AND BAIJIN2 AND BAIJIN3;
HUANGJIN1:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;
HUANGJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
M2:=HUANGJIN1 AND HUANGJIN2;
XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5   AND GJTJ1>GJTJ4;
M3:=COUNT(XG,3)=1 AND XG AND C>MA(C,20);
A:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1;
B:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A1:=A AND B;
AA:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BA:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A2:=AA AND BA ;
AAA:=BARSLAST(CROSS(97,GJTJ1))<=3 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAA:=BARSLAST(CROSS(97,GJTJ2))<=3 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A3:=AAA AND BAA ;
B1:=REF(A1,1);
B2:=REF(A2,1);
B3:=REF(A3,1);
D1:=GJTJ1=100 AND GJTJ2=100   AND A1;
D2:=GJTJ1=100 AND GJTJ2=100   AND A2;
D3:=GJTJ1=100 AND GJTJ2=100   AND A3;
AQ:=BARSLAST(CROSS(GJTJ4,GJTJ1))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
BQ:=BARSLAST(CROSS(GJTJ4,GJTJ2));
DQ:=GJTJ3<GJTJ4 AND GJTJ2<GJTJ4;
EQ:=BARSLAST(CROSS(GJTJ4,GJTJ3))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
FQ:=GJTJ2<GJTJ3 AND GJTJ2<GJTJ4 AND GJTJ2<GJTJ1 AND GJTJ1=100;
AW:=BARSLAST(CROSS(95,GJTJ1))<=2;
BW:=BARSLAST(CROSS(95,GJTJ2))<=2;
EW:= GJTJ4<GJTJ1 AND GJTJ1<GJTJ2 AND GJTJ1<GJTJ3;
FW:=GJTJ2>50 AND GJTJ3>50;
G:=GJTJ1=100 AND GJTJ2=100;
TX:=COUNT(G,2)=1;
AE:=GJTJ3=100;
BE:=GJTJ4<90;
操盘手: M1 OR M2 OR M3 OR D1 OR D2 OR D3 OR (AQ AND BQ AND DQ AND EQ AND FQ) OR (AW AND BW AND EW
AND FW AND TX) OR (COUNT(AE,2) = 2 AND BE);

加码
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
TR:=MAX(MAX((HIGH - LOW),ABS(REF(CLOSE,1) - HIGH)),ABS(REF(CLOSE,1) - LOW));
ATR:=MA(TR,14);
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
GG:B2=1;;

底跟上
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);  
BU:=CROSS(买线,卖线);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
EE:=CROSS(FF,MA15);
TR:=MAX(MAX((HIGH - LOW),ABS(REF(CLOSE,1) - HIGH)),ABS(REF(CLOSE,1) - LOW));
ATR:=MA(TR,14);
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
黑牛均线:BU OR B1=1 OR B2=2 OR EE;

黑牛均线
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);  
BU:=CROSS(买线,卖线);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
EE:=CROSS(FF,MA15);
TR:=MAX(MAX((HIGH - LOW),ABS(REF(CLOSE,1) - HIGH)),ABS(REF(CLOSE,1) - LOW));
ATR:=MA(TR,14);
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
黑牛均线:BU OR B1=1 OR B2=2 OR EE OR B2=1;

追涨选股
DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*30;
DEA:=EMA(DIF,9);
VAR4:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR5:=SMA(VAR4,3,1);
VAR2:=SMA(VAR5,4,1)-90;
CROSS(DIF,VAR2)AND VAR2<REF(VAR2,1);
一招绝
VAR326:=IF(CLOSE>REF(CLOSE,1),88,0);
VAR327:=IF(CLOSE/REF(CLOSE,1)>1.050   AND HIGH/CLOSE<1.010 AND VAR326>0, 91, 0);
XG:FILTER(VAR327>1,5);

老鼠仓
AA1:=AMOUNT/VOL;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:BB1 AND CC1 AND DD1 AND EE1;

抄底高手
VAR1:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100<-30;
VAR2:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100<-27;
VAR3:=VAR1 AND VAR2;
VAR4:=VAR1 AND VAR2 AND COUNT(VAR3,2)=1 AND DATE>940101 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 AND (REF(OPEN,1)>REF(CLOSE,1) OR REF(OPEN,1)<REF(CLOSE,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5));
VAR5:=DMA(EMA(CLOSE,8),SUM(VOL,9)/2.8/CAPITAL);
VAR6:=(CLOSE-VAR5)/VAR5*100;
VAR7:=REF(VAR6,1)<-42 AND VAR6>REF(VAR6,1) AND REF(VAR6,1)<REF(VAR6,2) AND VAR6-REF(VAR6,1)>1.8;
抄底高手:VAR4 OR VAR7,COLORWHITE;

逆市买入
VAR31:=DMA(CLOSE,VOL/MA(VOL,4)/4);
VAR32:=DMA(CLOSE,VOL/MA(VOL,32)/32);
VAR33:=(CLOSE-VAR31)/VAR31*100<-8;
VAR34:=(VAR31-VAR32)/VAR32*100<-21;
VAR35:=VAR33 AND VAR34 AND (OPEN>CLOSE OR OPEN<CLOSE) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.05 AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5)) AND (REF(OPEN,6)>REF(CLOSE,6) OR REF(OPEN,6)<REF(CLOSE,6)) AND (REF(OPEN,7)>REF(CLOSE,7) OR REF(OPEN,7)<REF(CLOSE,7));
VAR36:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100<-23;
VAR37:=(INDEXC-LLV(INDEXL,275))/(HHV(INDEXH,275)-LLV(INDEXL,275))*100;
VAR38:=SMA(VAR37,50,1);
VAR39:=SMA(VAR38,40,1);
VAR3A:=VAR36 AND VAR39<23 AND COUNT(VAR36,2)=1 AND (OPEN>CLOSE OR OPEN<CLOSE) AND OPEN/REF(CLOSE,1)>0.96;
逆市买入:VAR35 OR VAR3A,COLORBLUE;

市场赢家
VAR41:=CLOSE/MA(CLOSE,30)*100<75;
VAR42:=CLOSE/MA(CLOSE,50)*100<78;
VAR43:=HIGH>LOW*1.053;
VAR44:=VAR43 AND COUNT(VAR43,5)>2;
VAR45:=VAR44 AND (VAR41 OR VAR42);
VAR46:=DMA(EMA(CLOSE,5),SUM(VOL,8)/2.8/CAPITAL);
VAR47:=(CLOSE-VAR46)/VAR46*100;
市场赢家:REF(VAR47,1)<-34 AND VAR47>REF(VAR47,1) AND REF(VAR47,1)<REF(VAR47,2) AND VAR47-REF(VAR47,1)>1.76 OR VAR45,COLORMAGENTA;

旭日东升
VAR51:=(CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100<-23;
VAR52:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100>16;
VAR53:=100*(HHV(HIGH,27)-CLOSE)/(HHV(HIGH,27)-LLV(LOW,27));
旭日东升:VAR51 AND VAR52 AND CROSS(VAR53,79) AND (OPEN>CLOSE OR OPEN<CLOSE) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)<0.05 AND VOL>MA(VOL,23),COLORRED;

沿途打劫
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
XG:(K<EMA(K,4) AND K>REF(K,1));

疯牛买点
VAR1:=MA(HHV(HIGH,485),17);
VAR2:=MA(HHV(HIGH,222),17);
VAR3:=MA(HHV(HIGH,96),17);
VAR4:=MA(LLV(LOW,485),17);
VAR5:=MA(LLV(LOW,222),17);
VAR6:=MA(LLV(LOW,96),17);
VAR7:=MA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,17);
VAR8:=MA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,17);
VAR9:=MA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,17);
VARA:=MA((VAR7*3+VAR8*2+VAR9)/6*1.738,17);
VARB:=IF(V>0,VARA,VARA*DAY);
VARC:=LOW;
VARD:=REF(LOW,1);
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),2,1)*100;
VARF:=MA(IF(CLOSE*1.35<=VARB,VARE*10,VARE/10),2);
VAR10:=LLV(LOW,30);
VAR11:=HHV(VARF,30);
绝佳买点:=IF(V>0,MA(IF(LOW<=VAR10,(VARF+VAR11*2)/2,0),2),100000000);
I:=IF(CLOSE<REF(CLOSE,1),VOL/CAPITAL*10053,0);
骤雨初晴:= ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);

IF(CROSS(绝佳买点,24000),15,0 ) ;
砍庄低吸
砍庄刀:=LLV(SUM( EMA((C+L)/2,2)/2.98,3),4);
杀庄刀:=(SUM(EMA((C+L)/2,2)/2.98,3));
XG:(砍庄刀=杀庄刀);

SOS
VAR1:=(2*CLOSE+HIGH+LOW)/4.0168;
VAR2:=LLV(LOW,34);
VAR3:=HHV(HIGH,34);
大兵:=EMA((VAR1-VAR2)/(VAR3-VAR2)*100,13),COLOR0033FF;
CROSS(大兵,27);

百法百中
VAR7:=MA(INDEXC,62)<REF(MA(INDEXC,62),1) AND MA(INDEXC,105)<REF(MA(INDEXC,105),1) AND MA(INDEXC,62)<MA(INDEXC,105)*0.98;
VAR8:=MA(INDEXC,32)>MA(INDEXC,6)*1.11 AND MA(INDEXC,24)>MA(INDEXC,6)*1.095;
VAR9:=MA(INDEXC,6)>INDEXC*0.95;
VARA:=H>L*1.078 AND COUNT(H>L*1.078,4)>2;
百法百中:VARA AND (C/MA(C,48)*100<67 OR C/MA(C,50)*100<69) OR VAR7 AND VAR8 AND VAR9 AND C/COST(8)<=0.8 AND COUNT(C=O,2)=0;

乘胜追击
VAR4:=(WINNER(C)-WINNER(O))>=0.3 AND MA(V,6)/MA(V,26)>=1.9 AND V>REF(V,1) AND COUNT(SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100<20,20)>=1 AND C/MA(C,3)>=1.07;
VAR5:=(WINNER(C)-WINNER(O))>=0.4 AND MA(V,8)/MA(V,45)>=2.5 AND COUNT(SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100<20,20)>=1 AND C/MA(C,3)>=1.05 AND C>MA(C,85) AND V>REF(V,1);
乘胜追击:(VAR4 OR VAR5);

短线黑马
VARB:=(C-DMA(C,V/MA(V,4)/4))/DMA(C,V/MA(V,4)/4)*100<-11 AND (DMA(C,V/MA(V,4)/4)-DMA(C,V/MA(V,33)/33))/DMA(C,V/MA(V,33)/33)*100<-22.3 AND (O-REF(C,1))/REF(C,1)>-0.07 AND COUNT(C=O,8)=0;
VARC:=(C-DMA(CLOSE,VOL/MA(VOL,3)/3))/DMA(CLOSE,VOL/MA(VOL,3)/3)*100<-5;
VARD:=(DMA(CLOSE,VOL/MA(VOL,3)/3)-DMA(C,V/MA(V,33)/33))/DMA(C,V/MA(V,33)/33)*100<-18;
VARE:=VARC AND VARD AND (O-REF(C,1))/REF(C,1)>-0.05 AND COUNT(C=O,2)=0 AND SMA(SMA((INDEXC-LLV(INDEXL,250))/(HHV(INDEXH,250)-LLV(INDEXL,250))*100,30,1),50,1)<20;
短线黑马:(VARB OR VARE AND COUNT(VARE,2)=1);

牛市专利
VAR12:=(C-MIN(REF(C,3)*0.844,REF(C,13)*0.767))/C<0.07 AND SUM(100*V/CAPITAL,3)/3<2.345 AND INDEXC>MA(INDEXC,450) AND MA(INDEXV,61)/MA(INDEXV,80)>0.923 AND C>MA(C,190);
VAR13:=INDEXC>MA(INDEXC,450) AND (C-MA(C,20))/MA(C,20)*100<-16.5 AND MA(INDEXV,61)/MA(INDEXV,80)>0.92
AND C>MA(C,215) AND V/CAPITAL<0.075 AND COUNT(C=O,5)=0;
牛市专利:(VAR12 OR VAR13) AND HHV(C,440)/LLV(C,440)<4;

顺势搭轿
顺势搭轿:(C-MA(C,48))/MA(C,48)*100<-28 AND SMA(MAX(C-REF(C,1),0),12,1)/SMA(ABS(C-REF(C,1)),12,1)*100>23 AND VOL>MA(VOL,18) AND COUNT(C=O,6)=0;
抄底高手1
VAR1:=(C-MA(C,48))/MA(C,48)*100<-30 AND (C-MA(C,70))/MA(C,70)*100<-27 AND COUNT((C-MA(C,48))/MA(C,48)*100<-30 AND (C-MA(C,70))/MA(C,70)*100<-27,2)=1 AND (O-REF(C,1))/REF(C,1)>-0.07 AND COUNT(C=O,6)=0;
VAR2:=(C-DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL))/DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL)*100;
VAR3:=REF(VAR2,1)<-42 AND VAR2>REF(VAR2,1) AND REF(VAR2,1)<REF(VAR2,2) AND VAR2-REF(VAR2,1)>1.8;
抄底高手:(VAR1 OR VAR3);

逆势买入1
VARF:=(C-DMA(C,V/MA(V,4)/4))/DMA(C,V/MA(V,4)/4)*100<-8 AND (DMA(C,V/MA(V,4)/4)-DMA(C,V/MA(V,32)/32))/DMA(C,V/MA(V,32)/32)*100<-21 AND (O-REF(C,1))/REF(C,1)>-0.05 AND COUNT(C=O,8)=0;
VAR10:=SMA(SMA((INDEXC-LLV(INDEXL,275))/(HHV(INDEXH,275)-LLV(INDEXL,275))*100,50,1),40,1);
VAR11:=(C-MA(C,70))/MA(C,70)*100<-23 AND VAR10<23 AND COUNT((C-MA(C,70))/MA(C,70)*100<-23,2)=1 AND (O>C OR O<C) AND O/REF(C,1)>0.96;
逆势买入:(VARF OR VAR11);

市场赢家1
VAR14:=H>L*1.053 AND COUNT(H>L*1.053,5)>2 AND (C/MA(C,30)*100<75 OR C/MA(C,50)*100<78);
VAR15:=DMA(EMA(C,5),SUM(V,8)/2.8/CAPITAL);
市场赢家:REF((C-VAR15)/VAR15*100,1)<-34 AND (C-VAR15)/VAR15*100>REF((C-VAR15)/VAR15*100,1) AND REF((C-VAR15)/VAR15*100,1)<REF((C-VAR15)/VAR15*100,2) AND (C-VAR15)/VAR15*100-REF((C-VAR15)/VAR15*100,1)>1.76   OR VAR14;
旭日东升1
旭日东升:(C-MA(C,50))/MA(C,50)*100<-23 AND SMA(MAX(C-REF(C,1),0),3,1)/SMA(ABS(C-REF(C,1)),3,1)*100>16 AND CROSS(100*(HHV(H,27)-C)/(HHV(H,27)-LLV(L,27)),79) AND (O>C OR O<C) AND (O-REF(C,1))/REF(C,1)<0.05 AND V>MA(V,23);

神密线
X1:=(EMA(C,5)-EMA(C,13))/EMA(C,13)*100;
X4:=(EMA(C,5)-EMA(C,120))/EMA(C,13)*100;
Y1:=3*SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1);
Y2:=2*SMA(SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
Y3:=Y1-Y2;
Y4:=100-Y3;
Y5:=(0-(EMA(Y4,1)-50))+50;
Y6:=(0-(EMA(Y4,12)-50))+50;
X5:=V/CAPITAL*(C+O+L+H)/4;
X6:=(H-MAX(C,O))-(MIN(C,O)-L)+(C-REF(C,1));
X7:=IF(X6>0,X5,0-X5);
X8:=H-MAX(C,O)-(MIN(C,O)-L);
X9:=(X7+X8)/2+C-REF(C,1);
X10:=SUM(X9,0)+100;
X11:=EMA(X10,5)+100;
X12:=EMA(X10,13)+100;
X15:=EMA(X10,120)+100;
X16:=(X11-X12)/EMA(C,13)*100;
X19:=(X11-X15)/EMA(C,13)*100;
X20:=(X19-X16);
Z1:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1);
Z2:=2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
Z3:=(Z1-Z2-50)*1.032+50;
Z4:=(2*C+H+L+O)/5;
Z5:=EMA((Z4-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100,13);
P0:=X4-X1+X20+Y5-Y6,COLORYELLOW;
P4:=(Z3-Z5)/2+P0,COLORGREEN;
CROSS(P4,P0) AND P4<40;

买进选股
A7:=(2*C+H+L)/4;
底:=LLV(A7,21);
顶:=HHV(A7,21);
SK:=EMA((A7-底)/(顶-底)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
买进:IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>6/10 AND VOL>=1.5*MA(VOL,5)
AND COUNT(SK>=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),COLORFF0098;

抄底选股
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
抄底:IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),COLORWHITE;

全仓买
上线:=SMA(C,6.5,1);
下线:=SMA(C,13.5,1);
全仓买:CROSS(上线,下线);

KD抄底
RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
SUM(CROSS(K,D)AND D<23,15)>=2 AND CROSS(K,D)AND C>O;
买点选股
VAR1:=MA(WINNER(CLOSE),9)*100;
CROSS(VAR1,2);

转强选股1
M6:=EMA(C,60);
M7:=MA(C,78);
M8:=EMA(M7,3);
M9:=EMA(M8,3);
选股:CROSS(M6,M9);

转强选股2
Y:=(H+L)/2;
AO:=MA(Y,5)-MA(Y,34 );
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF(TDU3<TUD3,REF(HHV(H,2),TDU3),REF(LLV(L,2),TUD3)),COLORYELLOW;
JDU0:=REF(C,1)<=REF(UDGLINE,1) AND C>UDGLINE AND TDU0<TUD0;
JUD0:=REF(C,1)>=REF(UDGLINE,1) AND C<UDGLINE AND TUD0<TDU0;
JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JUD2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
选股:JUD2;

新友选股
VAR326:=IF(CLOSE>REF(CLOSE,1),88,0);
VAR327:=IF(CLOSE/REF(CLOSE,1)>1.050   AND HIGH/CLOSE<1.010 AND VAR326>0, 91, 0);
XG:FILTER(VAR327>1,5);
招财猫
A1:=(C-REF(C,1))/REF(C,1)*100;
MA5:=BARSLAST(A1>3);
Z1:=MA(C,13);
ZX:=REF(Z1,13/2+1);
MA20:=IF(MA5>0,1,0);
选股:CROSS(C,ZX) AND MA20=0;

核心拉力
DP:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
GG:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
VAR1:=IF(DP>0.01,0.9,IF(DP<-0.05,1,1.2));
VAR2:=VAR1*(GG-DP)*100;
核心拉力:=SUM(VAR2,5);
R5:核心拉力>REF(核心拉力,1) AND REF(核心拉力,1)<REF(核心拉力,2) AND REF(核心拉力,1)<-6;

导弹选股
VAR1:=(((CLOSE)/(MA(CLOSE,40)))*(100) < 78);
VAR2:=(((CLOSE)/(MA(CLOSE,60)))*(100) < 74);
VAR3:=(HIGH >= (LOW)*(1.051));
VAR4:=VAR3 AND (COUNT(VAR3,5) >= 2);
VAR4 AND VAR1 OR VAR2 AND (COUNT((HIGH = LOW) AND (CLOSE = OPEN) AND (CLOSE < REF(CLOSE,1)),3) = 0) AND (HHV((VOL)/(CAPITAL),30) < 0.8),COLORYELLOW;
买点
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
指导线:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2);
界:=MA(CLOSE,27);
B买:CROSS(指导线,界) OR CROSS(买线,卖线);

绝杀选股
M1:=SUM((EMA((CLOSE + LOW)/(2),2))/(2.98),3),COLORFFFFFF;
M2:=EMA(M1,21),COLORFF00FF;
M30:=MA(CLOSE,30),LINETHICK1,COLORFF0000;
VAR1:=(2)*(MA((LLV((CLOSE + LOW)/(2),8))*(1.1),13)) - EMA((CLOSE + LOW)/(2),3) - ((CLOSE + LOW)/(2))*(0.1);
VAR2:=IF(((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5) > 0),(POW((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5),2))/(10),(((-1))*(POW((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5),2)))/(10));
VAR3:=IF((VAR2 > 0),VAR2 - 0,(-1));
绝杀:CROSS(VAR3,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8));

买点1
B:=ZIG(3,50/5)*100,COLORWHITE;
G:=MA(B,2),COLORYELLOW;
买:(CROSS(B,G)*1000 AND ZIG(3,50/5)*100)*10,COLORRED;
底部买入
RSV:=((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*(100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=(CLOSE-LLV(CLOSE,62))/(HHV(CLOSE,62)-LLV(CLOSE,62))*100;
VARB:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
VARC:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VARD:=SMA(VARC,3,2);
VARE:=SMA(VARD,3,2);
AA:=EMA(VARE,2);
买入:AA<20 AND AA>REF(AA,1)AND REF(AA,1)<REF(AA,2);

海风战神
LC:=REF(CLOSE,1);
TR:=MAX(HIGH - LOW,MAX(HIGH - LC,LC - LOW));
ATR:=SMA(TR,20,1);
AA:=HHV(HIGH,30) - (2)*(ATR);
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=(BBB = 0) AND (REF(SSSB,1) < REF(BBB,1));
B1B:=BARSLAST(B1);
B2:=(BB = 1) AND (B1B < SSSB) AND (B1B > 0) AND (COUNT(BB,SSSB) < 3);
B2B:=BARSLAST(B2);
重仓选股:(BB = 1) AND (B2B < B1B) AND (COUNT(BB,SSSB) < 4) AND (COUNT(BB,SSSB) > 2);

TD80
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
K:=EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,8),COLORYELLOW ;
D:=EMA(0.667*REF(K,1)+0.333*K,2),COLORWHITE;
XG:CROSS(K,D)*50;
明天买入
JQ1:=100-(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))*100;
JQ2:=100-(HHV(HIGH,17)-CLOSE)/(HHV(HIGH,17)-LLV(LOW,20))*100;
JQ3:=100-(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*100;
买入:IF(JQ1>34 AND JQ2>34   AND JQ3<11,-11,0);

中线选股
N1:=BARSLAST(CROSS(MA(C,20),MA(C,40)));
N2:=BARSLAST(CROSS(MA(C,60),MA(C,20)));
V1:=IF(N1<N2,N1+1,0);
N3:=BARSLAST(CROSS(MA(C,20),MA(C,60)));
N4:=BARSLAST(CROSS(MA(C,60),MA(C,20)));
V2:=IF(N3<N4,N3+1,0);
N5:=BARSLAST(CROSS(MA(C,40),MA(C,60)));
N6:=BARSLAST(CROSS(MA(C,60),MA(C,40)));
V3:=IF(N5<N6,N5+1,0);
JT:=V1 AND V2 AND V3;
季托:CROSS(JT,0.5);

明天低买1
VAR1:=1992231;
VAR2:=IF(DATE<=VAR1,1,0);
VAR3:=1/WINNER(CLOSE);
VAR4:=MA(CLOSE,13);
VAR5:=100-ABS((CLOSE-VAR4)/VAR4*100);
VAR6:=LLV(LOW,75);
VAR7:=HHV(HIGH,75);
VAR8:=(VAR7-VAR6)/100;
VAR9:=SMA((CLOSE-VAR6)/VAR8,20,1);
VARA:=SMA((OPEN-VAR6)/VAR8,20,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=3*VARA-2*SMA(VARA,15,1);
VARD:=100-VARC;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<55 AND VAR17>50;

明天低买CGL90%: IF(CROSS(VAR20,0.5),8,0)*VAR2,COLOR00FFFF ,LINETHICK2;

明天低买2
AA:=LLV(LOW,34);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
绝谷:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
买入成功率80%:IF(CROSS(绝谷,90) AND (DD<40),8,0),COLORFFFF00;

免责声明:本网站所有内容,仅作为备案存档用,不作为任何人投资决策依据,据此操作,风险自担。联系QQ:1419255708。免责条款.首页..ICP备17011151号